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SmallMap Manual

1. General information

SmallMAP is a tool for creating vector maps based on raster backgrounds, and processing
spatial information. The application is based on the Firebird 3.0 relational database. It allows
you to collect and process raster data and vector layers. Currently, the program works with
spatial  data  in  WGS84  system and  Web Mercator  projection.  It  operates  in  two  modes:
viewing and editing of objects. The default unit of the program is one meter.

2. Raster data

The program does not create new rasters, but you can add/import them via the Layers-> Add
Raster Layer menu or the button  in the docked Layers window. So you can add an existing
raster from the database, i. e. previously imported rasters (Fig. 1), combine existing rasters
(Merge rasters) or import them from a (Geo)TIFF file, provided that it refers to the WGS84
ellipsoid.

 

Fig. 1. Add Raster dialog window. Adding a raster layer from the database.

The Add Raster dialog window also allows you to remove rasters from the database (button
) and change the name of a given raster layer (button  ). The Merge Rasters option has

four filters defined: Near Infrared, True-Color, Shortwave Infrared 1 and 2, which are used to
combine images from the respective LandSat image ranges. If the option of raster import has
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been selected, the program will load the source file and then you need to specify the raster
type by selecting it from the list of all defined types (Fig. 2).  Name and  Description fields
have only informative significance to the user.

 

Fig. 2. Raster Info dialog window. Raster data import.

After loading into the program, raster files are positioned, and 8-bit and 16-bit rasters are
displayed in gray scale, by default.

3. Vector data

Creating new vector layers and opening the existing ones is enabled by the  Layers-> Add
Vector Layer menu (or button  ), which launches the  Add Vectors dialog with three tabs
(buttons): New Vectors, Add Vectors, and Import Vectors (Fig. 3).

 

Fig. 3. Add Vectors dialog window. Adding a vector layer from the database.
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The program allows you to import vector data from SHP files and GPX files (from GPS) -
after pressing the Import Vectors button. Because SHP files do not contain information about
colors and formatting shapes, when importing these files, the program displays a window with
a selection of the necessary data (Fig. 4).

 

Fig. 4. Dialog window for formatting imported data from SHP files.

The program supports the following vector shapes: symbols, points, polylines, polygons, text
labels and grid cells.

4. Preview mode

 

Fig. 5. Program in the preview mode. Loaded raster layer and vector layers.
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Preview mode is activated through the View-> Preview Mode menu or by pressing the button
 on the left bar. In the preview mode the loaded layers are visible in the order they were

added, while the raster layers are always "at the bottom", i. e. visible in the background (Fig.
5). You can change the order of displaying layers (Layers-> Move Up/Down, or buttons  
and   in the  Layer Manager  tab), and hide them (icon  ). The loaded layer can also be
centered (button ) or removed from the list (button )1. These options are also available in
the edit mode.
In  the  preview mode,  the  image  visible  in  the  main  program window can  be  moved  by
pressing the left mouse button (the cursor changes to ), and change its scale with the mouse
wheel or in the drop-down list on the top bar. At the same time, the current cursor position is
displayed in the status bar: in meters and degrees, and if a raster image containing elevation
data has been loaded, the height in m a.s.l. is also displayed. Moreover, in the preview mode
you can find the scale in [km] or [m] in the bottom left corner of the image (map), and a wind
rose in the upper right corner. After hovering over a given vector shape on the map, a hint
window with the name of the object will appear just below the mouse cursor. Also you can
measure a distance in straight line from any point using mouse (Tools->Measure, icon  ).
The result will appear at the status bar.

 

Fig. 6. Preview for image export to EMF/WMF file.

In the preview mode, you can export your work result to vector Windows metafiles (EMF,
WMF) by choosing an option Map->Export to Image or pressing the button  on the top bar,
and then selecting the area to be exported with the mouse (the cursor will change to "cross").
The export preview window will appear (Fig. 6). The image in the export preview (i. e. the
map) contains automatically matched meridians and parallels, and legend elements defined in
the layer attributes. Meridians, parallels,  and map borders (axes) can be turned off in the
Format-> Grid and Format-> Axes menu, respectively.

1 This does not remove the layer physically from the database.
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Fig. 7. Legend properties dialog window.

The program also enables a detailed formatting of the legend area by the option available in
the Format-> Legend... menu. This option allows you to change the position of the legend, set
the number of columns in which the legend elements are arranged, and change the visibility of
these elements, as well as edit the caption (Fig. 7). After closing the export preview window,
the program restores the previous view of the preview mode. The visible map image can be
saved to a file by choosing File-> Save or the button .

 

Fig. 8. Print preview window.

Similarly, the option of exporting the selected area to a printer works by calling the Map->
Export to Printer menu or by pressing the button  . The print preview window (Fig. 8)
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allows you to change the printer  as well  as  the page format  and orientation (button  ).
Moreover,  the edges of the image (map) can be snapped to the width of the page (menu
Format-> Fit  to Page) or centered on the page (Format-> Center in Page).  The printing
process is started by pressing the button .

Fig. 9. 3D view window.

Raster data and some of vector data, in particular objects of varied elevation, can be exported
to a 3D view. Choose the menu option Map-> Export to 3D View or press the button  on the
top bar and select the area (object) to be exported with the mouse cursor. The export preview
(Fig. 9) works like a typical 3D object viewer, with options to rotate and zoom in/out.

5. Edit mode

Edit mode is activated through the View-> Edit Mode menu or by pressing the button  on
the left bar. You can edit such objects as raster and vector layers, and vector shapes. Modified
layers in the layer list are marked with '*', and they are automatically saved in the database.

Raster layers can be selected by clicking the left mouse button on the workspace (unless they
are covered by other layers) or by selecting them from the list of layers (Layer Manager tab).
Then  the  list  of  layer  properties  will  appear  in  the  Inspector tab  showing  the  name,
description, type, palette and range of the palette of the layer. The name and description of the
layer can be edited in all types of raster layers, while in case of rasters containing 8-bit and
16-bit data also the color palette and its range can be modified (Fig. 10). Predefined palettes
are: in gray scale or inverted gray scale, spectral and hypsometric.
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Fig. 10. Window for choosing the color scale and palette range of the raster layer.

Vector layers and shapes can be selected by clicking the left mouse button on the workspace
(unless they are covered by other layers/shapes) or by selecting them from the list of layers
and shapes: their properties appear in the Inspector tab showing the name, description, legend
and number of shapes (the last is read-only mode). With regard to vector shapes you can edit
the name, visibility level2 and, depending on the type of shape, its properties such as style and
color of the edge/fill, etc. The latter features appear in the bottom bar below the workspace in
a form of drop-down lists, edit fields or buttons.

 

Fig. 11. Selected vector shape (polygon) with handles.

2 Visibility level is useful when a given object is to be visible only on a specific map scale.
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After selecting the vector shape, node handles appear around its edges (Fig. 11). Each node
can be moved with the mouse; you can also add or remove the existing nodes by holding the
CTRL button. Moreover, selected shapes can be moved (see the respective cursors in the table
1).

 

Fig. 12. Adding and removing polygon nodes using mouse.

Mouse cursor Action

Moving node points

Adding node points

Removing node points

Moving selected shapes

Table 1. Mouse cursors during edition of a vector shape.

You can also edit manually the location of node points of the selected shape. After selecting
the list of elements, a window with a list of points and their location will appear in the shape
properties window (Fig. 13). The point order number corresponds to the node number. For
comparison,  you  can  activate  the  Shapes->Show  Handle  Labels option,  then  the  order
numbers of nodes will appear next to the handles.

 

Fig. 13. Editable list of node points of the selected shape.
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Colors and edge styles as well as fill colors of the shape can be defined on the bottom toolbar
(Fig. 11). To change the color of the border or fill of a given shape, click the appropriate box
(Border/Line Color, Fill Color) on the bar. Then a dialog box will appear that allows you to
select a color from one of the predefined color palettes, either in RGB/HSV modes, or choose
a color according to Albert Munsell's classification (Fig. 14).

 
a

 
b

Fig. 14. Color selection dialog window: a) manual mode; b) Munsell’s scale.

The program allows you to use text labels. In edit mode you can change their attributes such
as: size3,  font color and style,  rotation angle and text alignment (options available on the
bottom toolbar). The text is aligned with the insertion point (node), with possible values such
as: centering, right alignment and left alignment. The program also allows you to manually
rotate the text label with the mouse (Fig. 15).

3 The text size is a value that corresponds to the font size, but calculated relatively to the default map scale (see
Map-> Information... menu). This means that if the font size is 12 and the default map scale is e.g. 1:10,000,000,
then on this scale the text label will have the size of 12.
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Fig. 15. Rotating the text label of the center alignment using the mouse.

Selected shapes can be cut, copied to the clipboard, pasted and deleted. These options are
available in the Edit menu, on the upper bar of the program window (buttons  , , , and

, respectively) and through standard keyboard shortcuts. Selected shapes can also be moved
to the top of the layer or to the bottom of other shapes of a given layer - menu  Shapes->
Bring to Front/Send to Back.

The program also allows you to add new shapes on the selected layer - through the Shapes->
Add Shape menu or by pressing an appropriate button on the left bar. Currently, you can add:
symbols (icon ), points (icon ), polylines (icon ), polygons (icon ), and text labels
(icon ), by clicking on the point where a new node should appear; the operation of adding
node points can be terminated by pressing ESC. With regard to polylines and polygons, they
can be converted to each other. Moreover, selected polyline can be divided into shorter ones
cutting it by line at any angle, using knife tool (Shapes->Knife, icon ).

 

Fig. 16. Group of highlighted polylines (rivers) within the selected area.

You can also highlight a group of shapes. After selecting the  Shapes-> group Shapes menu
(icon   on the left bar), use the mouse to select the area containing shapes of the current
layer to be highlighted. The entire shapes within this area will be marked in red against the
gray background of the other layers (Fig. 16).
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Fig. 17. Editing visual attributes of the group. The color and style of the polygon edges have changed.

The group thus marked can be cloned into a new layer (icon  on the bottom bar), and the
visual  features  of  these  shapes  can  be  edited  collectively  (icon  )  by  changing  the
characteristics of the selected shapes (Fig. 17). It is possible to undo the last stage of editing
the visual features of the group.

For vector layers, you can edit the legend associated with the layer. In the list of layers, select
the desired layer, and then call the Legend item from the Inspector tab. The legend item editor
window will appear, allowing you to add, remove and move the order of selected items (Fig.
18). The editor allows you to insert symbols, shapes (linear and rectangular) and texts into the
legend.

 

Fig. 18. Legend items editor.

Elements of the legend associated with a given layer are visible in the preview mode on the
Legend tab.
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6. Symbol library

In the Tools-> Symbol library menu, you can find a tool designed for editing the existing and
creating new symbols used in  symbol shapes (Fig. 19). There are three basic shapes: circle,
square and triangle, whose visual features, namely the color of the fill and the border, can be
changed, giving the names to the symbols created in this way. The default symbol is a yellow
circle with a black border - this is the shape for undefined symbols on the map.

Fig. 19. Symbol editor.

7. SQL queries

The program provides you with an access, in read-only mode, to database structures used to
define maps, layers, shapes and others, using SQL queries. This option is available in the
Tools-> SQL query menu or the toolbar button . In the left panel of the window (Fig. 20), a
list of tables (map layers; icon ), columns of individual tables (icon ), including columns
with a master key (icon ) and a list of available functions (icon ) are visible in a form of a
tree structure.

Using  the  SQL query  language,  the  user  can  create  a  report  using  data  from any  table
contained in the database (see Figure 20), but it is not possible to modify, add or delete any
data.

Queries are stored in the default "SQLs/" directory. They are edited in the window with the
highlighted SQL syntax. The queries are launched by File-> Execute (F8) command or the
button  on the toolbar. If the query generates results, they are displayed in a form of a list
that appears below the editing window; otherwise, the user is notified about the result of the
query via a pop-up window with an appropriate message. If a query error occurs, relevant
information appears in the status bar or in the information pop-up.
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Fig. 20. SQL Query editor window.

If the results of the SQL query include shape identifiers of the current layer, it is possible to
highlight them on the map (see Fig. 16). To do this, select  Tools-> Add Group from Result
(icon ) and specify the map layer and the field (name) of the shape identifier (Fig. 21). This
option is available if the edit mode is checked.

 

Fig. 21. Window for selecting layer and shape identifier from the results of the SQL query.

8. Context menu

The program provides you with a quick access to the most-used main menu options via the
context menu. In the workspace, the pop-up menu allows you to change the working mode
(preview/edit) and provides options for cutting, copying, pasting and removing shapes, as well
as  adding  new and conversions  of  existing  ones  (Fig.  22).  The  program also  provides  a
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context menu in the layer list area (Layer Manager), allowing you to add, delete and save
edited layers.

 

Fig. 22. Context menu in the workspace.

9. Data stores

The raster data, including their thumbnails created for different levels of the map scale (raster
mosaic), is stored by default in the database. This solution may, however, be uncomfortable,
therefore you can specify additional places (Data stores) to store this data, e. g. in a selected
folder on the hard drive. To do this, select Tools-> Data Stores menu and specify the location
of additional data stores (Fig. 23).

 

Fig. 23. Data Stores editing window.

You can also move the data from one place to another. The Tools-> Move Data option is used
for this purpose.
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10. Plug-ins

All imports  of external  files (i.  e.  raster and vector layers) into the program are possible
thanks to the mechanism of plug-ins, the number of which is gradually increased. Currently,
the program supports the following external data formats4:

Plug-in Notes
TiffLib TIFF rasters converter
GELib GoogleEarth cache data converter
ShpLib SHP vectors converter
GpxLib GPX vectors converter (from GPS devices) 
GMLib MAP vectors converter
DBFLib DBF vectors converter (points and labels)

Moreover,  through  the  plug-in  mechanism,  LandSat  imagery  channel  mixing  (bands)  is
performed, enabling e. g. visualization of near-infrared satellite images (Fig. 24).

 

Fig. 24. Raster layer in true-color mode on the background of infrared image.

11. Generators

The program enable the generation of vector layers based on existing data or information
delivered  by  the  user,  through  the  mechanism of  generators  (menu  Layers->  Generate).
Currently the following generators are available in the program:

Generator Notes
GridGen Generator of are grid
IsoGen Generator of isolines based on a height map

4 Some features of the external formats are not yet supported.
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The number of available generators is increasing gradually. So far, it is possible to generate
the Are grid in relation to the reference point, useful e. g. in archaeology to determine the
examined area of the site (Fig. 25).

 Fig. 25. Are grid generator window.

Another application is generating of isolines based on the heighmap of given area. To do this,
select the SRTM raster layer in preview mode and, after starting the generator window (Fig.
26),  specify  parameters  such  as  height  range,  step  between  isolines  and  size  of  the
interpolated image cell (they affect the detail of the result).

Fig. 26. Isolines generator window.
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Fig. 27. Isolines generated each 100 m on raster background.

The colors of individual isolines are determined automatically on the basis of the color palette
of the raster background, although their tone is slightly darker. The result is a set of polylines
(Fig. 27), which can be edited in the program in a standard way (see Chapter 5).

12. Work with GPS receiver

The program allows you to receive data from a U-blox 7 GPS receiver (Fig. 28a) connected to
a computer via USB and exposed as a serial COM/ACM port on desktop. To use the receiver,
you must first configure the connection by selecting the View->Options… menu and then, in
the dialog window, the GPS Receiver frame (Fig. 28b).

a

b

Fig. 28. GPS receiver: a) device; b) configuration of connection.
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The default ports are: COM3 (Windows) and /dev/ttyACM0 (Linux), but the port numbers are
assigned  by  the  operating  system  and  may  be  different  from  the  default  ones.  The
recommended baud rate is 9600 bps. To test the selected configuration, you can use the Test
button.5. 

Fig. 29. Application in GPS receiver operation mode.

To  enable  and  disable  the  transmission  from the  GPS  receiver,  select  the  Tools->  GPS
Receiver menu item. Then, on the toolbar will appear a new section containing information
about  the  currently  visible  satellites  (diagram),  the  current  position  of  the  receiver
(coordinates and level above sea level), the number of satellites used to calculate it and the
horizontal error coefficient (Fig. 29). If the application is running in the preview mode, a
mark  will appear on the map in place of the current coordinates of the receiver. Moreover,
when you select  Layers-> Center GPS Position,  the current layer will  be centered to the
current GPS coordinates.

5 On Linux systems, attempting to connect to the receiver may result in an error in accessing the port pseudo-file
(permission denied). You should then make sure that the user belongs to the dialout group.
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